Wed. Dec 4th, 2019

Host your Website

Read and learn

FatCow Web Hosting $1.00/mo* Trust your web hosting to the #1 web host provider, GoDaddy!

Kali Linux: Hacking Networks Part 1

3 min read



It’s so easy to hack badly configured networks using Kali Linux! Make sure you have configured your networks securely! Otherwise, look at how simple it is to hack networks using Kali Linux running on a Windows 10 computer. Applications like Yersinia make hacking with Kali Linux super easy! It’s important that you as a network professional know how to protect networks from hackers. Even the new Cisco CCNA 200-301 exam covers some of these hacking topics. Don’t just learn the theory of hacking, learn how to hack practically.

In this Ethical Hacking with Kali Linux playlist, I’m going to show you step by step how to hack and protect networks. This is white-hat hacking, not black-hat – in other words this is about teaching you Ethical hacking to help you better secure your networks!

In this video I’ll show you how to get started with Yersinia and hack CDP and Spanning Tree Protocol (STP). In subsequent videos I’ll show you how to hack other protocols.

Menu:
Overview: 0:01
Yersinia Overview: 0:58
Install Yersinia: 3:08
Yersinia options: 4:07
Run Yersinia: 4:40
Use Putty to view Switch configuration: 5:38
Bridge Kali Linux to the physical Ethernet network: 10:28
CDP flooding: 11:40
Spanning Tree (STP) hacking: 13:49

======================
Previous Video:
======================
Kali Linux installation video: https://youtu.be/AnwgxRtWXLI

======================
CCNA content:
======================
Free CCNA content: https://www.youtube.com/playlist?list=PLhfrWIlLOoKM3niunUBTLjOR4gMt_uR_a

CCNA course: http://bit.ly/2PmTVPD

======================
Free Network Software:
======================
Solar-PuTTY: http://bit.ly/SolarPutty
SolarWinds TFTP Server: http://bit.ly/2mbtD6j
WAN Killer: http://bit.ly/wankiller
Engineers Toolset: http://bit.ly/gns3toolset
IP Address Scanner: http://bit.ly/swipscan
Network Device Scanner: http://bit.ly/swnetscan
Wifi Heat Map: http://bit.ly/wifiheat
Wifi Analyzer: http://bit.ly/swwifianalyzer
SolarWinds NPM: http://bit.ly/getnpm

kali linux
Hacking
Ethical hacking

EVE-NG
GNS3
VIRL
Packet Tracer
10x Engineer
CCNA
Cisco Devnet Associate

CCNP Enterprise
CCNP Security
CCNP Data Center
CCNP Service Provider
CCNP Collaboration
Cisco Certified Devnet Professional
Cisco Certified Network Professional

LPIC 1
LPIC 2
Linux Professional Institute
LX0-103
LX0-104
XK0-004

Please note that links listed may be affiliate links and provide me with a small percentage/kickback should you use them to purchase any of the items listed or recommended. Thank you for supporting me and this channel!

========================
Switch configuration:
========================

c2960-CG# sh run
Building configuration…

Current configuration : 2984 bytes
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname c2960-CG
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
!
ip dhcp pool vlan1
network 10.1.1.0 255.255.255.0
default-router 10.1.1.254
dns-server 10.1.1.254
!
ip dhcp pool vlan2
network 10.1.2.0 255.255.255.0
default-router 10.1.2.254
dns-server 10.1.2.254
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface Vlan1
ip address 10.1.1.254 255.255.255.0
no ip route-cache
!
interface Vlan2
ip address 10.1.2.254 255.255.255.0
no ip route-cache
!
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
line con 0
line vty 0 4
password cisco
login
transport input all
line vty 5 15
login
!
end

========================

#kalilinux #ethicalhacking #hacker

43 thoughts on “Kali Linux: Hacking Networks Part 1

  1. Menu:

    Overview: 0:01
    Yersinia Overview: 0:58
    Install Yersinia: 3:08
    Yersinia options: 4:07
    Run Yersinia: 4:40
    Use Putty to view Switch configuration: 5:38
    Bridge Kali Linux to the physical Ethernet network: 10:28
    CDP flooding: 11:40
    Spanning Tree (STP) hacking: 13:49

    ======================
    Previous Video:
    ======================
    Kali Linux installation video: https://youtu.be/AnwgxRtWXLI

    ======================
    CCNA content:
    ======================
    Free CCNA content: https://www.youtube.com/playlist?list=PLhfrWIlLOoKM3niunUBTLjOR4gMt_uR_a
    CCNA course: http://bit.ly/2PmTVPD

    ======================
    Free Network Software:
    ======================
    Solar-PuTTY: http://bit.ly/SolarPutty
    SolarWinds TFTP Server: http://bit.ly/2mbtD6j
    WAN Killer: http://bit.ly/wankiller
    Engineers Toolset: http://bit.ly/gns3toolset
    IP Address Scanner: http://bit.ly/swipscan
    Network Device Scanner: http://bit.ly/swnetscan
    Wifi Heat Map: http://bit.ly/wifiheat
    Wifi Analyzer: http://bit.ly/swwifianalyzer
    SolarWinds NPM: http://bit.ly/getnpm

    ========================
    Switch configuration:
    ========================

    c2960-CG#sh run
    Building configuration…

    Current configuration : 2984 bytes
    !
    version 15.0
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname c2960-CG
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    !
    ip dhcp pool vlan1
    network 10.1.1.0 255.255.255.0
    default-router 10.1.1.254
    dns-server 10.1.1.254
    !
    ip dhcp pool vlan2
    network 10.1.2.0 255.255.255.0
    default-router 10.1.2.254
    dns-server 10.1.2.254
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    !
    !
    !
    !
    !
    !
    !
    !
    vlan internal allocation policy ascending
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/1
    !
    interface GigabitEthernet0/2
    switchport access vlan 2
    switchport mode access
    spanning-tree portfast
    !
    interface GigabitEthernet0/3
    !
    interface GigabitEthernet0/4
    !
    interface GigabitEthernet0/5
    !
    interface GigabitEthernet0/6
    !
    interface GigabitEthernet0/7
    !
    interface GigabitEthernet0/8
    !
    interface GigabitEthernet0/9
    !
    interface GigabitEthernet0/10
    !
    interface Vlan1
    ip address 10.1.1.254 255.255.255.0
    no ip route-cache
    !
    interface Vlan2
    ip address 10.1.2.254 255.255.255.0
    no ip route-cache
    !
    ip http server
    ip http authentication local
    ip http secure-server
    !
    !
    !
    !
    line con 0
    line vty 0 4
    password cisco
    login
    transport input all
    line vty 5 15
    login
    !
    end

    ========================

  2. Hi David,

    Very well explained video, slow pace and explaining all the little things, much appreciated will definitely look into more.

    Regarding what you showed us, can you tell me how could I detect that kind of activity, would the router have certain logs/events that would raise this to the surface?

  3. David, thanks for the interesting hacking series, please continue. Also, please tell how to recognize the attack and how to determine which port the attacker is sitting at. Thank.

  4. Hi David, i will be writing the CCNA CyberOps Exam(s) soon and wondering if you may have/recommend any courses relevant to the CyberOps exam(s). Thanks in advance!

  5. What method did you use as an outside attacker to get into my switch and router network? Are you going to suggest getting in thru a connected device on the same network? Perhaps a family member's phone that they have a rogue app or software installed on? Perhaps a rogue security update to an android designed specifically to hijack rhe connections'?

  6. Just passed my CompTIA Network+ last month and I'm glad I was able to follow along (for the most part). Saw some new Cisco protocols that weren't covered in Network+, I didn't know CDP? Have to look those up along with the program tools. Obviously Cisco proprietary protocols.

    With so many Kali tools it was good to see a list of them on tools.kali.com. Now I can go and research all of them and see what's available.

    Awesome content, and don't be afraid to plug your courses. You put out the best explanations and walk throughs.

  7. Hi David, thanks for making the videos, knowing that you are also using GNS3 with Mac, want to see if you have any recommendation for "chicken of VNC" replacement? It seems will not work anymore on Catalina

  8. Network Admin should shutdown unused ports and apply port security on active switch interface and disable DTP and VTP , change Default vlans and
    no cde enable on active switch ports other than uplink ports . CCNA teaches all these practices ! -> student at Cisco Networking Academy .

  9. Hi David…

    Excellent Video, Keep it up.I am very crazy these type of videos. I am learning day by day. Your Teaching method and explainaion both are good.

    I would request you that please make network diagram using GNS3 / White board with physical topology for better understanding.

    Many Thanks

    Regards

    Usman From Pakistan

  10. are we supposed to use default vlan in cisco switches, as I have learnt that using default vlan is insecure and need to move all un-used ports to another vlan.

    please advise. ta.

  11. In this video David said, you do not have to watch my course go watch other youtubers if u want but i assure you watch his tutorials. It will change ur life. (PS:yeah indeed there are a lot of good youtubers, I respect and love them as well). I am a simple guy, how do love hacking and i can tell u after knowing networking I do big steps in cyber security.So my friend, if u want to be a good network pentester (i hope one day aswell)then start with David's tutorials. PS: most of them here in youtube but do not forget go to udemy for more.

Comments are closed.

Copyright © All rights reserved. | Newsphere by AF themes.